[Cin] Help with performance problems

daniel-cinelerra-gg at opayq.com daniel-cinelerra-gg at opayq.com
Mon Dec 9 13:30:03 CET 2019

By the way, cpu usage seems lower when rendering 1080p than when rendering
4k, however 4k goes faster.

On Mon, Dec 9, 2019 at 1:09 PM Daniel Kinzelman <daniel-cinelerra-gg at opayq.com>

> Thank you all for your help!  I've tried your suggestions and things have
> improved somewhat (although unfortunately, I don't know exactly what action
> made the biggest difference).  I have successfully updated to the current
> version of Cinelerra in the repositories.
> I've done some additional testing and found strange results.  All of my
> testing was performed with the FFMPEG>Youtube>hd_h264.youtube preset.
> As a baseline, timeline playback with both 4k and 1080p runs at full
> framerate, or nearly full framerate (as long as no effects are enabled).
> Rendering a 4k video from a friend's camera with no effects takes about
> double real time.  Bitrate on this video is 95MB/s
> Rendering a 1080p video from my own camera, transcoded with ffmpeg to
> reduce bitrate to 10MB/s (native bitrate for this camera is unnecessarily
> extremely high) takes about triple real time.  This makes no sense to me
> since the source data rate for the 1080p files is so much lower, but
> perhaps my method of transcoding on file ingestion is faulty, and is
> creating problems for Cinelerra?
> Here is the command line I'm using to transcode when ingesting from my
> camera: -vcodec libx264 -preset fast -b:v 8000k -acodec copy
> Regarding HW acceleration, anything other than 'none' produces no output
> in the compositor and no video output in rendered files (although they sure
> render quickly!).
> Here's my video hardware:
> 05:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108GL
> [Quadro 600] [10de:0df8] (rev a1) (prog-if 00 [VGA controller])
> Subsystem: Hewlett-Packard Company GF108GL [Quadro 600] [103c:0835]
> Physical Slot: 2
> Flags: bus master, fast devsel, latency 0, IRQ 42, NUMA node 0
> Memory at ee000000 (32-bit, non-prefetchable) [size=16M]
> Memory at e0000000 (64-bit, prefetchable) [size=128M]
> Memory at e8000000 (64-bit, prefetchable) [size=32M]
> I/O ports at c000 [size=128]
> Expansion ROM at 000c0000 [disabled] [size=128K]
> Capabilities: [60] Power Management version 3
> Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
> Capabilities: [78] Express Endpoint, MSI 00
> Capabilities: [b4] Vendor Specific Information: Len=14 <?>
> As a side note, I've tried the 'Transcode' option and it broke my
> projects, gradually replacing videos on the timeline with videos which
> produced only a black screen.  I couldn't figure out how to backtrack and
> had to delete all configuration files and reinstall Cinelerra to fix this.
> Any advice?
> On Mon, Dec 9, 2019 at 6:03 AM Phyllis Smith  <
> > wrote:
>> Preview: As you can see from the responses already, there are a lot of
>> <>
>> This email is Masked using Blur - it was sent from lists.cinelerra-gg.org
>> to daniel-cinelerra-gg at opayq.com (your reply stays Masked). To protect
>> your privacy <https://www.abine.com/faq.html#caniaddcc>, do not forward
>> this message, or add new recipients like CCs or BCCs.
>> Thanks for being a Blur customer! If you haven't yet, [ Try DeleteMe at
>> a discount.
>> <https://joindeleteme.com/?utm_campaign=blur-offer&utm_source=masked-email-header>
>> ]
>> As you can see from the responses already, there are a lot of factors
>> that can affect render times! But I do not see this in a 720x576 video that
>> I rendered with file format ffmpeg/mp4.  It was a 4 minute video and took
>> only 32 seconds to render.  You can see in the attached file with another
>> window running "top" that shows %CPU = 1149 (so while rendering it is using
>> 11 1/2 cpus out of 16).  You can see on the timeline that the video is
>> about 4 minutes long and you can see in the lower left hand bottom corner,
>> that Rendering took...0.32 seconds.
>> In Settings->Preferences, Performance tab I have Cache set to 4096 and
>> SMP cpu count set to 16.  I have not looked at your screenshot in detail
>> yet, but will try to do so tomorrow.  In the Render menu, using the Video
>> wrench, I chose h264.mp4.  I will also try on a 1080p video.
>>> I am getting what I consider to be very slow render times and wanted to
>>> know if something is set up wrong.
>>> As a test, I imported a 1080p video from my camera, looped it several
>>> times and rendered it with no effects or compositing.  For a 4 minute video
>>> it took about 12 minutes to render as an .mp4.
>>> CPU usage never went above 23% and memory usage never went above 19%.
>> --
>> Cin mailing list
>> Cin at lists.cinelerra-gg.org
>> https://lists.cinelerra-gg.org/mailman/listinfo/cin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20191209/6e21e293/attachment.html>

More information about the Cin mailing list