[Cin] Test rendering whit x265

Andrea paz gamberucci.andrea at gmail.com
Fri Aug 13 15:10:08 CEST 2021

> try to put attched patch in thirdparty/src?
It looks like the same error:

[paz at arch-paz ~]$ git clone --depth 1
"git://git.cinelerra-gg.org/goodguy/cinelerra.git" cinelerra5
Clone in 'cinelerra5' in corso...
remote: Enumerating objects: 11722, done.
remote: Counting objects: 100% (11722/11722), done.
remote: Compressing objects: 100% (8758/8758), done.
remote: Total 11722 (delta 3335), reused 10524 (delta 2785), pack-reused 0
Ricezione degli oggetti: 100% (11722/11722), 145.30 MiB | 742.00 KiB/s, fatto.
Risoluzione dei delta: 100% (3335/3335), fatto.
[paz at arch-paz ~]$ cd /home/paz/cinelerra5/cinelerra-5.1
[paz at arch-paz cinelerra-5.1]$ git am /home/paz/Download/randrik15/*.patch
Applicazione in corso: Add timecode to output mov/mxf
Applicazione in corso: Hack: raise cpu cap from 8 to 16 (might have
bad effect on non-ffmpeg encoders)
Applicazione in corso: HACK: make avi demuxer in ffmpeg use
cin-specific seek flag (worked on dv avi)
Applicazione in corso: Hack : attempt to fix last flush in ffmpeg.c
Applicazione in corso: Fix mpeg2enc build/install (was broken by termux series)
.git/rebase-apply/patch:35: space before tab in indent.
        EncoderJob *job;
.git/rebase-apply/patch:36: space before tab in indent.
        mjpeg_debug( "Worker thread started" );
.git/rebase-apply/patch:46: space before tab in indent.
.git/rebase-apply/patch:47: space before tab in indent.
error: patch non riuscita: cinelerra-5.1/thirdparty/Makefile:397
error: cinelerra-5.1/thirdparty/Makefile: la patch non si applica correttamente
error: cinelerra-5.1/thirdparty/src/mjpegtools-2.1.0.patch5: non
esiste nell'indice
Patch non riuscita a 0005 Fix mpeg2enc build/install (was broken by
termux series)
suggerimento: Usa 'git am --show-current-patch=diff' per visualizzare
la patch non riuscita
Una volta risolto questo problema, esegui "git am --continue".
Se preferisci saltare questa patch, esegui invece "git am --skip".
Per ripristinare il branch originario e terminare il patching, esegui
"git am --abort".
[paz at arch-paz cinelerra-5.1]$ git am --abort

I tried to apply the mjpegtool-2.1.0.patch5 patch in src, but I can't
find the file to patch:

[paz at arch-paz src]$ patch < mjpegtools-2.1.0.patch5
can't find file to patch at input line 3
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
|--- ./mpeg2enc/seqencoder.cc.orig      2021-08-12 22:15:24.907277309 +0300
|+++ ./mpeg2enc/seqencoder.cc   2021-08-12 22:17:49.471277317 +0300
File to patch:

More information about the Cin mailing list