[Cin] Fade black flash

Phyllis Smith phylsmith2017 at gmail.com
Thu Jun 24 00:35:31 CEST 2021

A Freelancer has provided a fix for the fade bug in Title plugin and the
Dissolve transition BUT I can not
tell for sure if it is a correct fix (seems to work on Fedora O/S with your
black flash demo).  I have asked
IgorBeg to test if he has time.  A little more information is in BT #559.

If you would like to test for yourself, there is a new AppImage that works
on both older and newer distros at:
For those not yet familar with using an AppImage, all you have to do is
download the file (does not destroy
your current Cinelerra) and make it executable via a window command:
chmod +x cin_for_older_distros.AppImage
and then just run it from a window via:   ./cin_for_older_distros.AppImage

If anyone else tests, PLEASE provide feedback -- the only problem I had was
that for an older Ubuntu 16 distro
I have to use a new $HOME/.bcast5 to get it to work correctly.

On Tue, Mar 9, 2021 at 1:47 AM Camille Harang via Cin <
cin at lists.cinelerra-gg.org> wrote:

> I've attached the editing file along with the PNGs.
> Camille.
> Le 09/03/2021 à 01:41, Sam via Cin a écrit :
> Camille,
> I vaguely remember such a similar case, but it was a very long time ago,
> hence this old work around with the fade line.
> However, after trying to reproduce this problem currently, I have not
> succeeded. It runs fine every time, just like Phyllis, without the problem
> you describe.
> My question to you. Which Cinelerra version are you using? Can you show a
> screenshot or short video of your timeline scenario and what parameters are
> set on your end so we can better reproduce the error? Maybe we missed a
> setting you are doing and with an exact match of the setting we can
> reproduce this issue. Thanks in advance.
> Sam
> Am 09.03.21 um 00:48 schrieb Phyllis Smith via Cin:
> Camille,
> Honestly, I never see a flash and I have tried several variations based on
> your description with the "fade in text parameter" being the easiest.  I
> did do a recording of it and planned to show that but the recording does
> not do a precise capture job so you can not tell it is working correctly.
> There was no flash when playing at normal speed and then I tried single
> stepping and still no flash.
> Andrea,
> I will try attaching a screenshot of how to set this up easily with the
> hopes that you can try that.  Basically, I just created about 3 seconds of
> nothing and added a Title plugin making sure to set the Fade parameter on
> the Title menu to 3.0 seconds (I use the reset button first to make sure
> there are no leftover weird settings).
> On Mon, Mar 8, 2021 at 8:22 AM Camille Harang via Cin <
> cin at lists.cinelerra-gg.org> wrote:
>> Hi Sam, thanks for your reply, yes the fade line works, however it's not
>> suitable for what I want to do, I want to fade many snippets of text and
>> transparent PNGs on the same track, with always the same video transition
>> filter set to the same duration. Otherwise it's too complicated to combine
>> them on two tracks and adjust manually the fade curve for each. I posted
>> the example of fade in text parameter as it's simpler than transition do
>> explain, but it produces the same "black flash" bug.
>> Thank you,
>> Camille.
> --
> Cin mailing list
> Cin at lists.cinelerra-gg.org
> https://lists.cinelerra-gg.org/mailman/listinfo/cin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20210623/e40cf08f/attachment.htm>

More information about the Cin mailing list