[Cin] CinGG and ffmpeg 4.4

Andrea paz gamberucci.andrea at gmail.com
Sun May 2 11:02:49 CEST 2021

Hi, regarding the attempt to use ffmpeg-4.4, I realized that from a
certain point on the mails became private between Andrew and me and
therefore they do not appear in the mailing list. I will report here
the content of those mails, but I anticipate that I could not get
CinGG to work with ffmpeg-4.4.

Excluding patch5 we came close to completing the build. Now the errors
are about bdwrite and lv2.
Note: in Arch Linux lv2 are located in "usr/lib/lv2".
(thanks for the help you're giving me!)

Oh, this api hiding patch landed (it was reverted for 4.4 releases as
far As i know)

Try additionally patch Cin with this:

And may be

I am unable to patch the sources. I get the following error:

$ patch -p3 ffmpeg.C < ffmpeg.git_internal_api.patch
patching file ffmpeg.C
Hunk #3 succeeded at 4068 (offset 124 lines).
patching file ffmpeg.C
Hunk #1 FAILED at 89.
1 out of 1 hunk FAILED -- saving rejects to file ffmpeg.C.rej

(the same error exists also when I don't put -pX, or I put p0, p1, etc)

The contents of ffmpeg.C.rej are:

--- a/cinelerra-5.1/cinelerra/mainerror.h
+++ b/cinelerra-5.1/cinelerra/mainerror.h
@@ -89,7 +89,7 @@ private:

 // format text to error dialog listbox

-static inline void eprint1(const char *func, const char *fmt, ...)
+static  void eprint1(const char *func, const char *fmt, ...)
     char err_msg[1024], *cp = err_msg, *ep = cp + sizeof(err_msg)-1;
     va_list va;

I don't understand; first I patched mainerror.h and it seems OK. Then
I patched ffmpeg.C and it gives me the error, but the error seems to
refer to mainerror.h and not to ffmpeg.C.

I also tried to reverse the order of the patches but the result does not change.

I think working on the code is beyond my capabilities and I'm wasting
your time unnecessarily.

Try with git apply?

Error, again:

$ git apply ffmpeg.git_internal_api.patch
error: patch failed: cinelerra-5.1/cinelerra/mainerror.h:89
error: cinelerra-5.1/cinelerra/mainerror.h: patch does not apply

May be this part already change by previous patching? I think i rolled
two patches into one at some point.. Try to revert smaller patch

I've tried the patch revert; I've tried re-downloading all the source
and doing new tests. The result is always failure. I should know how
to get my hands on the code to find solutions to errors. But since I
don't know how to do that I would say I give up. Sorry for all the
time wasted. Thank you.

I attach the log of an attempt with only the mainerror_gcc5.diff patch
I started with a new "git clone" in order to have the system clean.
ffmpeg.git_internal_api.patch still doesn't work; probably due to my
Arch linux having differences with your Slackware.

Trying to replace ffmpeg-4.3 with ffmpeg-4.4 I don't know how to do in
a static build. But I guess that's beyond my poor skills as well.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cin5-only-mainerror-patch.tar.gz
Type: application/gzip
Size: 423015 bytes
Desc: not available
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20210502/079ec7d6/attachment-0001.bin>

More information about the Cin mailing list