[Cin] arm/termux series (possibly broken on x86)

Phyllis Smith phylsmith2017 at gmail.com
Wed Nov 17 02:32:09 CET 2021


> yeah, sounds like forcing ilmbase/openexr to be built in statically is way
> to go...
> The ilmbase IlmImf was still in the i386 AppImage and worked for Andrea
because it is a virtual system (at least I think so), as opposed to Debian
Bullseye (a real system) where the IlmImf so file still cause an immediate
crash.  The only way I can get rid of it in the build is to manually edit
configure.ac and comment it out.  On the configure line, I have tried
adding --without-openexr --without-ilmbase but it does not get rid of it.
Also, tried --without-ilmBase and disable-ilmbase and I just keep getting
illegal option.  But now I am side-tracked again.

*Question:*  before I check into GIT the following termux related mods
<http://CONFIGURE.AC>,* does libbthread need ifdefs around it?  It is not
causing a problem when I compile, but I don't know what will happen when
all of the rest of the libbthread patches are added.

0012-add-termux-specific-include-path.patch            *****randrik19/0007
0013-configure.ac-add-liconv-for-termux.patch         *****randrik19/0008
0021-add-libbthread-to-configure.ac-termux-specific.patch  ****************
Question?   *****randrik19/0015

Also, I have to test on i386 tomorrow before checkin.
Also Also, I forgot to download randrik19 but did so just now.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20211116/53e85a12/attachment-0001.htm>

More information about the Cin mailing list