[Cin] proot on termux

Andrew Randrianasulu randrianasulu at gmail.com
Mon Jan 10 07:06:57 CET 2022

I have i386 debian 11 on my arm tablet now, but road to it was somewhat

debootstrap as provided by termux does not like --foreign option, so I
tried modification of scrip commands found at

 (I have Android 10 tablet)

$ debootstrap --variant=minbase --exclude=systemd --arch=i386 bullseye

but you need to set main repo here or create debootstrap/mirror by hand


$ proot -0 -b /dev -b /sys -b /proc -b /system -b /apex --link2symlink -r
deb_11/ -q qemu-i386 /bin/bash --login

(for some reason my system need /system and /apex added to proot bind
directories for qemu to function)

this worked but ssl / ca-certificates were not installed, and coreutils for
some reason needed re-install by dpkg -i /var/cache/apt/archive/pkg.deb

also debootstrap/debootstap script had termux pathes in it, so I edited
them back for normal Linux/debian pathes

after installing /etc/resolv.conf network/apt worked but building man page
index was a bit slow.

Installing libgtk2.0-dev resulted in 1.011 Gb directory

simple openssl benchmark:

root at localhost:~# openssl speed sha256
Doing sha256 for 3s on 16 size blocks: 275533 sha256's in 3.00s
Doing sha256 for 3s on 64 size blocks: 175841 sha256's in 3.00s
Doing sha256 for 3s on 256 size blocks: 65455 sha256's in 3.00s
Doing sha256 for 3s on 1024 size blocks: 20649 sha256's in 3.00s
Doing sha256 for 3s on 8192 size blocks: 2779 sha256's in 3.00s
Doing sha256 for 3s on 16384 size blocks: 1389 sha256's in 2.98s
OpenSSL 1.1.1k 25 Mar 2021
built on: Tue Aug 24 08:28:12 2021 UTC
options:bn(64,32) rc4(8x,mmx) des(long) aes(partial) blowfish(ptr)
compiler: gcc -fPIC -pthread -Wa,--noexecstack -Wall -Wa,--noexecstack -g
-O2 -ffile-prefix-map=/build/openssl-eBODPh/openssl-1.1.1k=.
-fstack-protector-strong -Wformat -Werror=format-security
The 'numbers' are in 1000s of bytes per second processed.
type 16 bytes 64 bytes 256 bytes 1024 bytes 8192 bytes 16384 bytes
sha256 1469.51k 3751.27k 5585.49k 7048.19k 7588.52k 7636.70k

$ termux-info
Application version:
Packages CPU architecture:
Subscribed repositories:
# sources.list
deb https://termux.librehat.com/apt/termux-main/ stable main
# x11-repo (sources.list.d/x11.list)
deb https://packages.termux.org/apt/termux-x11 x11 main
# science-repo (sources.list.d/science.list)
deb https://packages.termux.org/apt/termux-science science stable
# game-repo (sources.list.d/game.list)
deb https://packages.termux.org/apt/termux-games games stable
Updatable packages:
mc/stable 4.8.27-2 arm [upgradable from: 4.8.25-3]
Android version:
Kernel build information:
Linux localhost 4.14.141+ #1 SMP PREEMPT Fri Dec 3 19:05:26 CST 2021 armv8l
Device manufacturer:
Device model:

$ lscpu
Architecture: armv8l
  Byte Order: Little Endian
CPU(s): 8
  On-line CPU(s) list: 0-7
Vendor ID: ARM
  Model name: Cortex-A53
    Model: 4
    Thread(s) per core: 1
    Core(s) per socket: 4
    Socket(s): 2
    Stepping: r0p4
    CPU max MHz: 2001.0000
    CPU min MHz: 400.0000
    BogoMIPS: 26.00
    Flags: half thumb fastmult vfp edsp neon vfpv3 tls vfp
                        v4 idiva idivt lpae evtstrm aes pmull sha1 sha2
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20220110/8c9f3f77/attachment.htm>

More information about the Cin mailing list