[Cin] Images sequence

Phyllis Smith phylsmith2017 at gmail.com
Wed Mar 9 06:03:29 CET 2022

As Andrew stated, first try with just the dpx modification and disable
compiling with dav1d to see if that at least builds.
You probably have changed the script bld.sh but you can see the disable
below in the one I use.  Just add --disable-dav1d to the configure line.

( ./autogen.sh
  ./configure --with-single-user --with-booby *--disable-dav1d*
  make && make install ) 2>&1 | tee log
mv Makefile Makefile.cfg
cp Makefile.devel Makefile

The current dav1d works with NASM 2.13 but I see Arch is at 2.15.  That
should not make a difference because generally later versions are
compatible with earlier versions.  Thank you for testing as we need to know
if the latest Arch has a problem with CinGG.

I've tried build CinGG from git both with Andrew's 3 patches and
>> without (so with only Phyllis' modification for dpx). In both cases I
>> get errors and the build fails (maybe due to x265 v3.5?). I attach the
>> 2 cin5.logs.
>> PS: I remember that I use Arch which is a rolling release and lately
>> there have been many updates of the graphics libraries. I think it's a
>> new problem of Arch that has nothing to do with the patches tried.
> may be compiler error? if you use gcc, try clang  instead or other way
> around?
> also, new nasm might give some errors..
> i see libopus, dav1d, libaom errors...
> try to disable some of those libs via configure switches tempirary?
> I look at log files in mcview, and search for 'errore' string....
> --
> Cin mailing list
> Cin at lists.cinelerra-gg.org
> https://lists.cinelerra-gg.org/mailman/listinfo/cin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20220308/a0a0e164/attachment-0001.htm>

More information about the Cin mailing list