[Cin] our opencv archive errors out on gcc 13 distros

Andrew Randrianasulu randrianasulu at gmail.com
Tue Dec 5 11:16:44 CET 2023

so, I tried to fix it in brutal way

download and unpack opencv 4.8.1 from their sf page.
98 mb or so
cd into it

cd opencv-opencv-7d2cb72/

mkdir build
cd build
cmake ..

try make, it will take some time.

but even if build fails we mostly interested in .cache directory.


copy that in our unpacked archive instead of 0.1.1f

download our archive from

unpack it into DIFFERENT directory.

change this file

AND also search for cmake downloader and replace it with one updated from
same 4.8.1 distribution


now from rootof directory  where two dirs from our archive {now updated}
exist you can call

tar -cvzf ../opencv-20200306-f.tgz .

and put this new archive into thirdparty and call configure with new file

Hopefully it will works even on fedora 38+

Currently testing on Slakel current , but I tried to be smart and cut down
build module lest, and this took few rebuilds to get right.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20231205/0da6ce5e/attachment.htm>

More information about the Cin mailing list