[Cin] some problems - batch rendering warnings and opening project error, steps to have cinelerraGG officially in Gentoo

Phyllis Smith phylsmith2017 at gmail.com
Mon Aug 5 02:23:59 CEST 2019


Hi, few days back I was with my low-end laptop Acer TravelMate B116-M on
> film camp where we helped children to took videos and then we cut them
> to final short films. I had weakest device on camp, but must say it
> worked quite well. I tested hw acceleration as it was announced here and
> it was quite stable

Interesting, thanks for sharing this!

> - laptop has Intel CPU and GPU so I used vaapi and
> h264_vaapi profile to speed up rendering. I tried to encode from 5 Mbps
> to 20 Mbps and noticed the few first frames of this hw encoded videos
> was quite low quality then it was better but lot of movement was lower
> quality also.
"According to an online wiki, hardware encoders usually create output of
lower quality than some
software encoders like x264, but are much faster and use less CPU." --- it
seems that the hardware acceleration is useful for initial
rendering/checking but for quality purposes, the slower software rendering
may be better for a final video.  I see no technical reason why the first
frames would be of lower quality so I will ask GoodGuy if he has an
explanation and I will run a test on a vaapi-enabled laptop here.

Then I loaded all saved parts to project as resources - it loaded saved
> parts as clips and all assets to resources. Then I pasted clips on
> timeline of final video and made final cut. Then I saved final project.
> Closed Cinelerra then I was unable to reopen saved project - it only
> showed one of clips on timeline :-(
This is of major concern, although there have been no similar reports of
"unable to reopen saved project", as you never want to lose work.  If you
still have the errant project file, GoodGuy would really like to see it to
maybe determine a problem (you can send it to me at phylsmith2017 at gmail.com
to keep it private or which ever way works for you).

> I then wanted to run jobs but it warned about mismatch of session/job so
> I must render separate :-(
> I rendered by jobs before without problems the same way. So I don't know
> what the problem was.
This error message creates some confusion -- in lots of cases, it is best
to uncheck "warn if jobs/session mismatch".  So I suggest leave this box
unchecked in your case.  The "warn if mismatch" checks the timeline and the
batch job to see if the user changed something on the timeline and forgot
to re-save and thus the changes would be loss - so it is a valuable test.
But with multiple jobs, it is probably always a mismatch.  A lot of things
have changed in Cinelerra, so it is possible that it worked for you before
but a redraw or something working a little differently than before may now
result in a mismatch.

> I'm using git versions - I work on Gentoo and I'd be happy to have
> official ebuild for this. I made first steps for that:
> https://bugs.gentoo.org/691102

I did look at this.  That would be great!

I think it would be better to build only production versions from git
> i.e. if somewhere was some info about what build is last production it
> could be somehow in ebuild to decide to build stable or latest git version.
We do builds on the last day of each month (currently, but the last day of
the month for us in Colorado may actually be the first day of the month in
Europe) and we consider this to be a stable release. If you look at the
following URL and see the comment as "*version update*" that is considered
a release:
However, it may be too much to do a Gentoo build every month - perhaps
every 6 months is more reasonable.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20190804/c90c6244/attachment.html>

More information about the Cin mailing list