[Cin] some problems - batch rendering warnings and opening project error, steps to have cinelerraGG officially in Gentoo

deim31 deim31 at gmail.com
Sun Aug 4 15:33:41 CEST 2019

Hi, few days back I was with my low-end laptop Acer TravelMate B116-M on 
film camp where we helped children to took videos and then we cut them 
to final short films. I had weakest device on camp, but must say it 
worked quite well. I tested hw acceleration as it was announced here and 
it was quite stable - laptop has Intel CPU and GPU so I used vaapi and 
h264_vaapi profile to speed up rendering. I tried to encode from 5 Mbps 
to 20 Mbps and noticed the few first frames of this hw encoded videos 
was quite low quality then it was better but lot of movement was lower 
quality also.

I had problems also with this method of work:
- load assets for part of video
- cut everything for this part on timeline
- save project
- repeat for each part

Then I loaded all saved parts to project as resources - it loaded saved 
parts as clips and all assets to resources. Then I pasted clips on 
timeline of final video and made final cut. Then I saved final project. 
Closed Cinelerra then I was unable to reopen saved project - it only 
showed one of clips on timeline :-(

So I decided to export only parts and concatenate exported videos.
The method was this:
- load part
- create new batch job (use current EDL button)
- set output path and codecs

I then wanted to run jobs but it warned about mismatch of session/job so 
I must render separate :-(
I rendered by jobs before without problems the same way. So I don't know 
what the problem was.

I'm using git versions - I work on Gentoo and I'd be happy to have 
official ebuild for this. I made first steps for that:

I think it would be better to build only production versions from git 
i.e. if somewhere was some info about what build is last production it 
could be somehow in ebuild to decide to build stable or latest git version.


More information about the Cin mailing list