[Cin] Slackware-14.2 x64 package wrongly packaged?

Andrew Randrianasulu randrianasulu at gmail.com
Mon Dec 30 05:56:59 CET 2019

В сообщении от Monday 30 December 2019 03:47:12 Phyllis Smith написал(а):
> Andrew, just to let you know that we "think" we have an updated Slackware
> build machine ready for the December 31 builds.
> >
> > I use slapt-get [1] for upgrades ....
> >
> > [1] - https://software.jaos.org/
> >
> > Yes, gg was using slapt -u and slapt --upgrade.  First try, he did an
> upgrade on the Slackware build used for the November 30th builds BUT ended
> up with the kernel version 4.14.47 dated May 2018 and "modules" dated May
> 30, 2018.  This seemed to be wrong already since neither the kernel or
> modules had changed.  Then when he ran "startx", the graphics card lost its
> configuration -- the keyboard interface died but the kernel continued for a
> little longer but then died too.  So it was dead.  Next he started from
> scratch with an install of Slackware from the original CD ISO of the
> current 14.2 release of June 2016 and then did an upgrade.  This seemed to
> work correctly.  We will see what happens in the Cinelerra build on
> December 31.

Hm, may be config file  /etc/slapt-get/slapt-getrc was pointing at wrong branch?

Default probably was configured for 14.2, and 'downgrading' to this from -current not exactly worked?
Slackware's pkgtool usually can up- and down- grade packages without checking if upgraded package actually
older than one it about to replace. So, it 'worked' until it failed... I think.

Check config file so it contains line like:

without "#" before it.

And i think -current even changed some locations for info about packages, 
so -14.2 slapt-get (0.10.2t) may not work with -current anymore.


But again, whole exercuse was about moving to latest released slackware, 
so this problem should not bite you.

> In the past he has been able to install Slackware from the CD and upgrade 2
> times and then not a third or ever again.  Starting a fresh install every
> 2-3 months is too time-consuming as it takes a whole day.  We will see if
> this latest upgrade fixes some unknown problem preventing multiple upgrades.

Hm, make sure you have enough free space on /var and even / ? 
I think by default slapt-get keep downloaded packages there, and not clean them 
after upgrade .. so slapt-get --clean will remove them from cache...

I even ran into another problem in 64-bit chroot, because apparently slapt-get
wanted some /dev /dev/pts /sys and /proc mounted (so, I mounted them with --bind from host)
but you probably use some diifferent method (I never tried Xen, so I have no experience with it)

> Yeah, strange bug, I looked into slackbuild provided in blds dir, it looks
> > sane ...
> >
> Thanks for checking -- it is good to have someone look that is much more
> knowledgable in Slackware.  gg/phyllis

Good luck, and sorry for only noticing this problem late .....

More information about the Cin mailing list