[Cin] Test rendering whit x265

Andrea paz gamberucci.andrea at gmail.com
Thu Aug 12 19:54:17 CEST 2021

I tested with a build where all the patches are present.

> I think 0066 from this series should work even with ffmpeg 4.3...
> it should fix (hide?) those error messages at the end of fast encoding..
with x265 I still see several messages about the codec; with h264 I
don't see them. They don't look like error messages to me, so I don't
think they're what you're referring to.

> then you can test 0067/68  duo..
unlike my pdf now has the following results: RMB in any Gang mode does
not apply to unarmed tracks. Do these patches only apply to Gang
Channels and Gang Media?

> you already tested 0069 (but it alters historical behavior)
RMB on Gang None does not apply on unarmed tracks.

> then you can look into testing 0063 (just small build optimization)
makefile presents corrections. I don't know what test to do!

> then test 0044 whith as many avi files as you can (esp. big dv files with audio, i had some on my hdd from year 2006-11, seeking was broken there. this hack fixed them for me, by applying same seeking workaround as mkv)
I'm not sure how to test the seek; I put several dv files, I cut and
put transitions. the playback runs at the right fps without dips.
There are no messages to the terminal.

> then 0042 - should be simple in that it adds exr sequence as format for background render
exr sequence option has appeared. Sequence created more slowly. A
frame in jpeg is 14.7 KB, a frame in exr is 10.6 MB

> 0041 should provide some speedup on reverse fast playback of i-only files (think ffv1?)
I created a small file ffv1: normal and fast reverse = normal and fast
forward = same source fps

> 0039 may provide some decoding/encoding speedup in ffmpeg on your machine (cpu not capped to 8) but might break non-ffmpeg encoders like mpeg2 (watch out for this)
if it was what we saw before: I confirm the 16 threads: "filebase cpu
16". A render with mpeg2 leads to an error: "error render data". On
the terminal there are these lines:
tc: 0.000000
FileMPEG::open_file: Running
/home/paz/cinelerra5/cinelerra-5.1/bin//mpeg2enc -v 0  -b 0 -q 15 -a 1
-F 5 -H --no-constraints -V 500 -I 0 -M 16 -f 3 -g 45 -G 45 -s -R 0 -o
sh: line 1: /home/paz/cinelerra5/cinelerra-5.1/bin//mpeg2enc: No such
file or directory
filebase cpu 16
FFMPEG::open_decoder: some stream have bad times:
Decoder png does not support device type vaapi.
HW device init failed, using SW decode.
  err: Operation not permitted
filebase cpu 16
signal_entry_recoverable: got SIGPIPE my pid=4313
signal_entry_recoverable: got SIGPIPE my pid=4313
signal_entry_recoverable: got SIGPIPE my pid=4313
signal_entry_recoverable: got SIGPIPE my pid=4313
signal_entry_recoverable: got SIGPIPE my pid=4313
signal_entry_recoverable: got SIGPIPE my pid=4313
Render::render_single: Session finished.

> 0034 should give you gui format (pixels) selection in ffmpeg/yuv4mpeg muxer, good for piping non-4.2.0/8 bit data to external ffmpeg, watch out for hw acceleration breackage (should not happen but better to test) ..
Maybe I don't understand correctly. The render window for y4m presents
a choice of many pixel_formats. I tried a 422p10le render and it works
without error.

> 0033 stamps output (mov/mxfmmpeg?) with timecode of playback position at the time of encode on timeline - not sure how useful, but by manually offsetting timecode start you can easily make wideos with different startv timecode. watch out for dvd/bd creation breackage! (I think it dislikes non-0 start timecode)
Never created dvd: I tried it and in Batch Render 2 files were formed.
I started the render and at 100% of the first file I had a CinGG
crash. The terminal also closed so I have no error messages. I have no
dumps. The errors are probably because of me.

More information about the Cin mailing list