[Cin] New AppImage release with mostly only changes for Android/Termux builds

mnieuw at zap.a2000.nl mnieuw at zap.a2000.nl
Wed Dec 1 23:35:38 CET 2021


I will do that mkv test on the VM one, sometime tomorrow. I did render
a H.264 mp4 file after cutting a bit from the original (also MP4), and
the result was fine, video and audio.

The native one gave me problems installing, screen full of pixels,
which is a known problem (framebuffer mode does not work). The help of
the install screen led me to force VGA 80x25, and it installed smoothly.
But, after reboot, the Xserver does not start, you see it in its log in
/var/logs/Xorg... . Looking at "journalctl -b", there are errors with
amdgpu driver, failing firmware. I suspect my AMD video (built-in of
the CPU) is having driver problems. Need to find a fix, like forcing it
to use Vesa 800x600 or so, to get my XFCE desktop.
I have not tested sound yet. The network should be fine, the install
used it, and I did an "apt upgrade".
If you want to access samba shares, you might have to install
gvfs-backend, gvfs-fuse and smbclient.

The reason it probably works here in a VirtualBox VM is that it has a
different video card.

@Andrea, which video card do you use for your qemu VM? When trying to
build for qemmu/aarch64, I used virtio without acceleration, have you
tried VGA or QXL? They are easy to change using virt-manager. One of
the choices only gave you 800x600, can't quickly remember which one.


On Wed, 1 Dec 2021 13:22:52 -0700
Phyllis Smith via Cin <cin at lists.cinelerra-gg.org> wrote:

> MatN:
> Have you loaded a video file with audio that is of type mkv? that type
> seems to fail more often.
> But I am having difficulty with my Debian setup so that besides not
> getting out to the network, I have not yet got sound to work.
> I have been creating AppImage on Debian 9.1 32-bit the same way since
> May of this year and last month was the first time anyone mentioned a
> problem with it on Debian Bullseye.
> Andrea/Andrew:
> I have fixed the manual section on Android as you both noted.
> On Wed, Dec 1, 2021 at 9:05 AM mnieuw--- via Cin
> <cin at lists.cinelerra-gg.org> wrote:
> > @Andrea, it build and and works for in a VirtualBox VM, in 1386 and
> > x86_84. The Debian-11s were never before used to build, did you do a
> > sudo blds/bld_prepare.sh? It pulls in a lot of needed stuff.
> >
> > Am going to setup a native partition to do testing.
> >
> > MatN
> >
> >
> > On Wed, 1 Dec 2021 16:31:04 +0100
> > Andrea paz via Cin <cin at lists.cinelerra-gg.org> wrote:
> >  
> > > Nice section on Android/Termux; only at the beginning is there a
> > > CinGG to replace with \CGG{}.
> > > (32-bit appimage still doesn't work for me in Debian 11 32-bit
> > > with Qemu/Virt.  Probably something is missing in my Debian,
> > > which I don't know well because I've never been in the deb
> > > world.)  
> >
> > --
> > Cin mailing list
> > Cin at lists.cinelerra-gg.org
> > https://lists.cinelerra-gg.org/mailman/listinfo/cin
> >  

More information about the Cin mailing list