[Cin] [SemiOT] CUDA

Phyllis Smith phylsmith2017 at gmail.com
Tue Jun 25 21:39:18 CEST 2019

Andrea, somehow I missed this email.  Sorry.  Whenever you do not get a
timely response on an email "Question", please email again.  Although some
questions I do not answer because I am totally clueless and even then I
usually just say that.

In any case, being able to compile "deviceQuery" is not important,
> only that I get the same error if I try to compile Cuda in CinGG. Do I
> need to put in any particular instructions? (I used --with-cuda). I
> have to put the string on:
> -I/opt/cuda/include (vedi wiki più sotto)
> in the compiler? How do I do it? Do I have to compile CinGG as root?
> With the command "printenv" I see the voice: "CUDA_PATH=/opt/cuda"
> I report what Arch's wiki says:
> "The cuda package installs all components in the directory /opt/cuda.
> For compiling CUDA code, add /opt/cuda/include to your include path in
> ...
> Maybe Arch installs Cuda in /opt and Fedora in /usr/local/...?

Your statement just above this is correct.  GG will have to fix this for
Arch.  Attached is a corrected file that he will check in later (probably
today) but you can just write over the one you have in Cinelerra's toplevel
directory. AND as you stated you will have to use "setenv
CUDA_PATH=/opt/cuda" on the command line before compiling with-cuda. We
also tested on Leap the current way and that worked too.  Arch is a little
bit different animal!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20190625/5e8bb159/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: plugin_cuda
Type: application/octet-stream
Size: 1223 bytes
Desc: not available
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20190625/5e8bb159/attachment.obj>

More information about the Cin mailing list