[Cin] Render farm

Andrea paz gamberucci.andrea at gmail.com
Tue Mar 16 09:29:00 CET 2021

Since I keep having problems with multithreaded rendering (vedere
I tried again the render farm locally with only the threads of my CPU
(8/16); but it doesn't work for me.
When I try to start the client CinGG instances, instead of:

RenderFarmClientThread::run: Session finished

I get:

RenderFarmClient::main_loop:400: Address already in use

I first tried from root with ports 401 - 416. Then from no-root with
ports 1026 - 1041. The result is always the same.

The steps I take:
- Start CinGG and activate "use render farm" and then set the 15
clients as Localhost port 1026, ..., 1041. OK to activate.
- I open a terminal and start the following script:

for n in 'seq 1026 1041'; do
    /home/paz/Desktop/./CinGG-20210228-x86_64.AppImage -d $n

- I get the message reported before and the rendering does not work.
(the same happens with CinGG compiled)

Any advice?

More information about the Cin mailing list