[Cin] Crash on playback

Phyllis Smith phylsmith2017 at gmail.com
Fri Jan 21 04:46:00 CET 2022


> I could not get that to crash no matter what the settings.
That is consistent with what you have always said -- crash only happens
when you build it yourself.

It seems it will only do vdpau with X11, not X11 Opengl. With X11 Opengl,
> it says
> err: Operation not permitted
> FFStream::decode: failed
> HW device init failed, using SW decode.
> but it works fine with X11 direct render.
I saw no difference between using X11 and X11-OpenGL in my tests with
tutorial,mp4 using vdpau (my graphics board can not handle DSCF0220.MOV in
either vaapi or vdpau).  I think I have some more work to do to understand
what is going on because when I run the build binary, tutorial.mp4 works in
both vdpau and vaapi BUT the AppImage only works in vdpau.

How close is the test AppImage to what you need to accomplish what you
want? if I can not get any better results?
Logging off the computers for today!

> With X11 Direct Render it will play 10 bit 4K60 at 60 fps. I have a Nvidia
> GTX-1050 with 2 GB on this computer. With the price of video cards, that is
> all there is going to be.  I do have a GTX-1650 with 4 GB on another
> computer that runs Fedora 34, but that is the entertainment computer that
> is pretty much for watching the final result.

> Regards,
> Mark
> On Thu, Jan 20, 2022 at 6:51 PM Phyllis Smith <phylsmith2017 at gmail.com>
> wrote:
>> Mark,
>>> It does not crash when using X11 OpenGL, only X11. X11 with direct
>>> render does not seem to be faster when using vdpau, so I think I have a
>>> workable solution that does not require extra tracks.
>> Curiouser and curiouser.  I checked and I was using X11 and not OpenGL.
>> I have created a multibit AppImage on my Fedora 29 computer(which is an
>> HP/Intel/Broadwell graphics board) and have uploaded it.  When I tested
>> this AppImage moved to an AMD Ryzen-7 (with a Radeon graphics board) vdpau
>> worked for me on tutorial.mp4 file.  It did not work with DSCF0220.MOV
>> though probably due to limitations of my board.  When you have time and the
>> inclination, you should see if it works for you by downloading:
>> https://cinelerra-gg.org/download/testing/cin-x86_older-distros_multibit.AppImage
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20220120/8a1c7f8e/attachment-0001.htm>

More information about the Cin mailing list