[Cin] Images sequence

Phyllis Smith phylsmith2017 at gmail.com
Mon Mar 7 20:05:43 CET 2022

The ffmpeg TOC file does not need to contain the list of files.

Here is how to test this for TIFF files:
1) render using options: ffmpeg / tif
2) for ease of use, put the files in /tmp/test/test%5d.tif   (so create
/tmp/test directory first)
3) do the render and you will see that test%5d.tiff will contain ONLY:
# Frame rate: 29.970030
# Width: 352
# Height: 240
and all of the test00###.tiff files exist in the /tmp/test directory
4) now just add a video track and drag the test%5d.tiff from the Media
folder of the Resources window and it works correctly
    or later just load /tmp/test%5d.tiff and it works.

Now for the interesting part, yesterday and this morning DPX was working on
my builds and AppImages from October, November, and December UNTIL I switch
to using TIFF instead of DPX.  Now DPX no longer works so there is
something going on and I have not figured it out yet.  Also, yesterday, I
tried it on Arch dated 10/30/2020 and DPX did not work (have to check to
see if TIFF does).  The correct contents of the dpx file is:
# Frame rate: 29.970030
# Width: 352
# Height: 240
with NO listing of each individual dpx files needed.

> I tried to do a dpx render; it came with all the images and a TOC file
>> that doesn't have the links to the images. Then I created a second TOC
>> file using imagelist.sh. A TOC came up with the links to the dpx
>> images. This doesn't work when imported into CinGG; it's obvious
>> because imagelist.sh uses only jpeg images and not dpx.
>> So I took the first TOC and pasted in the links from the second TOC.
>> This TOC+ works in CinGG and Natron; it doesn't work in Kdenlive and
>> OpenShot (but I don't know if these programs support DPX).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cinelerra-gg.org/pipermail/cin/attachments/20220307/94eb2c4e/attachment.htm>

More information about the Cin mailing list